APIAny_​CheckPropertyExpressionStringID

Checks if the given property expression is a syntactically valid one.

    GSErrCode ACAPI_Goodies (
        APIAny_CheckPropertyExpressionStringID,
        GS::UniString*     expressionString
    );

 

Parameters

expressionString
[in] The expression whose validity is to be decided.

 

Return Values

NoError
The given expression string is a syntactically valid one.
APIERR_BADEXPRESSION
The given expression string is syntactically incorrect.
APIERR_BADPARS
Some of the parameters are nullptr.

For other common API errors see the API Errors document.

 

Remarks

This function is used to determine whether a property expression string is syntactically correct.

It tries to parse the expression, and APIERR_BADEXPRESSION is returned when it fails because of some syntax error.

 

Requirements

Version: API 22 or later
Header: APIdefs_Goodies.h

 

See Also

API_LibPart,
ACAPI_Goodies, API Functions