APIAny_​CompareLibPartUnIdsID

Compares two library part unique IDs.

    GSErrCode ACAPI_Goodies (
        APIAny_CompareLibPartUnIdsID,
        char*     unIDStr1,
        char*     unIDStr2
    );

 

Parameters

unIDStr1
[in] the first library part unique ID.
unIDStr2
[out] the second library part unuique ID.

 

Return Values

NoError
The function has completed with success and the two unique IDs are equal.
APIERR_NOTEQUALREVISION
The function has completed with success and the main GUID parts of the unique IDs are equal but the revision IDs differ.
APIERR_NOTEQUALMAIN
The function has completed with success but even the main GUID parts of the unique IDs differ.
APIERR_BADPARS
any of the parameters are nullptr.

For other common API errors see the API Errors document.

 

Remarks

This function is used to compare two library part unique IDs. Returns NoError if the IDs refer to the same library part with the same revision ID. APIERR_NOTEQUALREVISION is returned when the IDs still refer to the same library part with different revision IDs (different editions of the same library part). If the unique IDs refer to different library parts, APIERR_NOTEQUALMAIN is returned.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_LibPart,
ACAPI_Goodies, API Functions