APIAny_​ConvertPictureID

Converts a picture into another image format.

    GSErrCode ACAPI_Goodies (
        APIAny_ConvertPictureID,
        API_PictureHandle*     oldPict,
        API_PictureHandle*     newPict
    );

 

Parameters

oldPict
[in] Parameters of the source picture. The old format and data must be passed in the storageFormat and pictHdl fields, respectively.
newPict
[in/out] Parameters of the destination picture. The new format of the picture must be passed in the storageFormat field. The pictHdl field will be returned according to the specified format.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
parameters are nullptr or storage formats are invalid
APIERR_MEMFULL
Not enough memory to create the new pictHdl

For other common API errors see the API Errors document.

 

Remarks

This function is used to convert a picture from one standard image format to an other. Any picture format can be passed in both the input and output parameters.

See also APIAny_ConvertMimePictureID if you want to specify the image format using MIME types.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_PictureHandle
API_PictureFormat
APIAny_ConvertMimePictureID
ACAPI_Goodies
API Functions