APIAny_​DisposeRegularizedPolyID

Deallocates handles in an API_RegularizedPoly struct.

    GSErrCode ACAPI_Goodies (
        APIAny_DisposeRegularizedPolyID,
        API_RegularizedPoly*     regularizedPoly
    );

 

Parameters

regularizedPoly
[in] The polygon or polyline data to dipose.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
any of the parameters are nullptr or memo or insMemo is not initialized
APIERR_MEMFULL
low memory condition

For other common API errors see the API Errors document.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_Polygon,
APIAny_RegularizePolygonID, APIAny_RegularizePolylineID,
ACAPI_Goodies, API Functions