APIAny_​ElemHasVisibleSkinID

Returns if elem has visible skin depending on Partial Structure Display.

    GSErrCode ACAPI_Goodies (
        APIAny_ElemHasVisibleSkinID,
        const API_Guid*                  elemGuid,
        const API_StructureDisplay*      structure,
        bool*                      result
    );

 

Parameters

elemGuid
[in] Unique ID of the element.
structure
[in] The partial structure display.
result
[out] Returns if elem has visible skin.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
elemGuid does not refer to a valid element in the database.
APIERR_BADPARS
elemGuid or structure or result is nullptr.

For other common API errors see the API Errors document.

 

Remarks

This function tells if the element has any visible skin when the given partial structure display is in effect.

 

Requirements

Version: API 18 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies,
API Functions