APIAny_​EnableRenovationOverrideID

Enables renovation graphical overrides during ACAPI_Element_ShapePrims.

    GSErrCode ACAPI_Goodies (
        APIAny_EnableRenovationOverrideID,
        bool*                 oldOverrideVal,
        const bool*           newOverrideVal
    );

 

Parameters

oldOverrideVal
[out] Returns the current override state.
newOverrideVal
[in] The new override state.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function determines the behavior of the ACAPI_Element_ShapePrims function. If the renovation override is set then all primitive elements will be exported using the overriden attributes (as set in the graphical override attributes for the appropriate renovation filter).

APIAny_EnableRenovationOverrideID is only effective if APIAny_EnableVisualOverrideID is enabled.

 

Requirements

Version: API 15 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies,
API Functions