APIAny_​EnableVisualOverrideID

Enables graphical overrides during ACAPI_Element_ShapePrims.

    GSErrCode ACAPI_Goodies (
        APIAny_EnableVisualOverrideID,
        bool*                 oldOverrideVal,
        const bool*           newOverrideVal
    );

 

Parameters

oldOverrideVal
[out] Returns the current override state.
newOverrideVal
[in] The new override state.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function determines the behavior of the ACAPI_Element_ShapePrims function. If the override state is set then all primitive elements will be exported using the overriden attributes.

When APIAny_EnableVisualOverrideID is enabled, the renovation overrides can still be enabled or disabled with APIAny_EnableRenovationOverrideID.

 

Requirements

Version: API 20 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies,
API Functions