APIAny_​ExecuteSQLQueryID

Executes an SQL query.

    GSErrCode ACAPI_Goodies (
        APIAny_ExecuteSQLQueryID,
        const API_SQLQuery*     sQLQuery
    );

 

Parameters

sQLQuery
[in] The SQL query data.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
any of the parameters are NULL
APIERR_SQLPARSE
Error during parsing the sql query
APIERR_SQLEXECUTE
Error during executing the sql query
APIERR_SQLANY
Any error during the execution

For other common API errors see the API Errors document.

 

Remarks

This function is used to execute an SQL query even as you would type it in the Execute Query dialog of ARCHICAD.
The results of the query will be written into an xml file given in the queryStruct.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_SQLQuery, ACAPI_Goodies, API Functions