APIAny_​FreeMDCLParameterListID

Frees the parameter list handle.

    GSErrCode ACAPI_Goodies (
        APIAny_FreeMDCLParameterListID,
        GSHandle*     params
    );

 

Parameters

params
[in] Handle of the parameter list

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
params is nullptr

For other common API errors see the API Errors.

 

Remarks

This function is used to dispose a parameter list handle used in inter-addon communications.
For the utilization details of APIAny_FreeMDCLParameterListID refer to the Parameter Passing section of the Communication Manager.

 

Example

See the Communication_Manager example.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

Communication Manager
APIAny_AddMDCLParameterID
APIAny_ChangeMDCLParameterID
APIAny_GetMDCLParameterID
APIAny_GetMDCLParameterNumID
APIAny_InitMDCLParameterListID
ACAPI_Command_Call
ACAPI_Command_Test
ACAPI_Goodies
API Functions