APIAny_​GetActParametersID

Returns the actual (edited) values of a Library Part parameter list opened to edit.

    GSErrCode ACAPI_Goodies (
        APIAny_GetActParametersID,
        API_GetParamsType*     theParams
    );

 

Parameters

theParams
[out] the modified parameter list

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
theParams is nullptr
APIERR_NOTINIT
there is no parameter list opened

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the actual parameters modified by the APIAny_ChangeAParameterID function. Refer to the API_GetParamsType structure to get further details.

Do not forget to dispose the params handle when it is not needed any more. Refer to the ACAPI_DisposeAddParHdl to do that.

 

Example

See the example given at the APIAny_OpenParametersID function.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_GetParamsType,
APIAny_OpenParametersID, APIAny_ChangeAParameterID, ACAPI_DisposeAddParHdl,
ACAPI_Goodies, API Functions