APIAny_​GetContainingHotlinkGuidID

Retrieves the guid of the hotlink element which contains the given element.

    GSErrCode ACAPI_Goodies (
      APIAny_GetContainingHotlinkGuidID,
      const API_Guid*      elemGuid,
      API_Guid*            hotlinkElemGuid,
      nullptr
    );

 

Parameters

elemGuid
[in] The guid of the element.
hotlinkElemGuid
[out] The guid of the hotlink which contains the given element.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The elemGuid or the hotlinkElemGuid parameter is nullptr
APIERR_BADID
The passed elemGuid is invalid.

For other common API errors see the API Errors document.

 

Remarks

This function is used to obtain the hotlink element which contains the given element. If the passed element is not hotlinked element, hotlinkElemGuid will be set to APINULLGuid.

 

Requirements

Version: API 12 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies, API Functions