APIAny_​GetCWAbsoluteBottomID

Retrieves the the base height of a curtain wall or its subelem.

    GSErrCode ACAPI_Goodies (
        APIAny_GetCWAbsoluteBottomID,
        const API_Guid*     guid,
        double*             bottom
    );

 

Parameters

guid
[in] Curtain Wall or its subelem reference.
bottom
[out] Bottom of the element. This value is relative to the element’s home story.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
guid or bottom parameter is nullptr.
APIERR_BADID
guid is invalid.

For other common API errors see the API Errors document.

 

Remarks

This function is used to obtain the bottom of the curtain wall or its subelem (panel, fram, junction or accessory). As against the function name the bottom is relative to the element’s home story.

 

Requirements

Version: API 12 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies,
API Functions