Retrieves the height of a curtain wall element.
GSErrCode ACAPI_Goodies ( APIAny_GetCWHeightID, const API_Guid* guid, double* height );
Parameters
- guid
- [in] Curtain Wall reference.
- height
- [out] Height of the curtain wall.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
guid
orheight
parameter isnullptr
or theguid
is invalid.
For other common API errors see the API Errors document.
Remarks
This function is used to obtain the height – maximal difference of z
coords – of the curtain wall.
Requirements
- Version: API 12 or later
- Header: APIdefs_Goodies.h
See Also
ACAPI_Goodies,API Functions