APIAny_​GetCWSubElemParamsID

Returns the calculated additional parameters of a curtain wall subelem.

    GSErrCode ACAPI_Goodies (
        APIAny_GetCWSubElemParamsID,
        const API_Guid*       guid,
        API_AddParType***     psrsms
    );

 

Parameters

guid
[in] Curtain Wall subelem reference.
params
[out] Additional parameters of library part-based curtain wall subelem.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
guid or params parameter is nullptr or the guid is invalid.
APIERR_BADID
The given element os not library part-based.

For other common API errors see the API Errors document.

 

Remarks

This function is used to obtain the additional parameters of a library part-based curtain wall subelem (panel, frame, junction, accessory).
Don’t forget to call ACAPI_DisposeElemMemoHdls to dispose the params handle when you’re done.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 12 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies,
API Functions