APIAny_​GetElemCreatorToolUnIdID

Returns the unique ID of the creator tool of the specified object.

    GSErrCode ACAPI_Goodies (
        APIAny_GetElemCreatorToolUnIdID,
        API_Elem_Head*     elemHead,
        char*              unIDStr
    );

 

Parameters

elemHead
[in] the header or the element (only the guid field is required).
unIDStr
[out] the unique ID of the creator tool subtype.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
any of the parameters are nullptr, or the passed handles have wrong sizes.
APIERR_BADID
Not a Window, Door, Light or Symbol header was passed, or no element with the specified guid was found.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the creator tool of an element. Only elements of type window, door, symbol or light are accepted. The returned string is the unique ID of the template object of the creator tool.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_ElemHead,
ACAPI_Goodies, API Functions