Returns the library part unique identifier of the GDL based element (object/lamp/window/door).
GSErrCode ACAPI_Goodies ( APIAny_GetElemLibPartUnIdID, API_Elem_Head* elemHead, char* lpfUnId );
Parameters
- elemHead
- [in] Head of the element. It is identified by the
guid
field. - lpfUnId
- [out] The required unique ID in string format.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- One or both of the parameters is
nullptr
. APIERR_DELETED
- The element is deleted.
APIERR_BADID
- The element is not GDL based.
For other common API errors see the API Errors document.
Remarks
This function is used to get the library part unique ID in string format of the given element. The element is window, door, object or lamp
.
Requirements
- Version: API 12 or later
- Header: APIdefs_Goodies.h
See Also
ACAPI_GoodiesAPI Functions