APIAny_​GetElemTypeNameID

Returns the localized name of the built-in element types.

    GSErrCode ACAPI_Goodies (
        APIAny_GetElemTypeNameID,
        API_ElemTypeID     elemTypeID,
        GS::UniString*     elemName
    );

 

Parameters

elemTypeID
[in] The element type
elemName
[out] The name of the element type in the language of the ARCHICAD version currently running

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Invalid element typeID value.
APIERR_BADPARS
The passed elemName parameter is nullptr.

For other common API errors see the API Errors document.

 

Remarks

This function retrieves the name of the specified element type in the language the currently running program is localized for.

 

Example


API_ElemTypeID elemTypeID = API_AngleDimensionID;
GS::UniString elemName;
if (ACAPI_Goodies (APIAny_GetElemTypeNameID, (void *) (Int32) elemTypeID, &elemName) == NoError)
    DBPrintf ("Angle Dimension is called \"%s\"\n", (const char*) elemName.ToCStr ());

 

Requirements

Version: API 10 or later
Header: APIdefs_Goodies.h

 

See Also

API_ElemTypeID
ACAPI_Goodies
API Functions