APIAny_​GetHttpConnectionPortID

Returns the HTTP port number, on which Archicad is expecting requests.

    GSErrCode ACAPI_Goodies (
        APIAny_GetHttpConnectionPortID,
        UInt32*                portNumber
    );

 

Parameters

portNumber
[out] HTTP port number .

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
the portNumber parameter is nullptr.
APIERR_GENERAL
there is an internal error and the HTTP server could not be started.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the HTTP port on which the Add-On commands, registered via ACAPI_Install_AddOnCommandHandler, can be accessed.

 

Requirements

Version: API 25 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Install_AddOnCommandHandler,
ACAPI_Goodies, API Functions