APIAny_​GetIFCDifferenceStateID

It generates an IFC Difference based on the input parameters.

    GSErrCode ACAPI_Goodies (
        APIAny_GetIFCDifferenceStateID,
        const API_Guid*     	                viewGuid,
        const API_IFCTranslatorIdentifier*      ifcTranslatorIdentifier,
        API_IFCDifferenceGeneratorState*        ifcDifferenceState
    );

 

Parameters

viewGuid
[in] Is an unique identified of the View, which will be used for state generation.
ifcTranslatorIdentifier
[in] IFC Export Translator identifier.
ifcDifferenceState
[out] The resulting IFC Difference State.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Invalid view Guid or IFC Translator.

For other common API errors see the API Errors document.

 

Remarks

It generates an IFC Difference State.

 

Requirements

Version: API 23 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies