Returns the library part’s creator element type and variation ID.
GSErrCode ACAPI_Goodies ( APIAny_GetLibPartToolVariationID, API_LibPart* libPart, API_ToolBoxItem* toolboxItem );
Parameters
- libPart
- [in] Identifies the library part. A basic ACAPI_LibPart_Search is performed to extract the internal library part identifier.
- toolboxItem
- [out] The requested creator element type and variation ID.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- Any of the parameters is
nullptr
.
For other common API errors see the API Errors document.
Remarks
This function returns the element type and variation ID, retrieving it from the internal library part registry. This information is necessary when you want to place an object having a special variation ID.
Requirements
- Version: API 15 or later
- Header: APIdefs_Goodies.h
See Also
API_LibPart, API_ToolBoxItemACAPI_Goodies
API Functions