APIAny_​GetMDCLParameterID

Retrieves a parameter from the parameter list.

    GSErrCode ACAPI_Goodies (
        APIAny_GetMDCLParameterID,
        GSHandle               params,
        API_MDCLParameter*     mDCLParameter
    );

 

Parameters

params
[in] The handle of the parameter list
mDCLParameter
[out] Pointer to the requested parameter

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
params or par is nullptr
APIERR_BADNAME
The passed parameter name is not found on the parameter list
APIERR_BADINDEX
The passed parameter index is out of range (checked only if par->name is nullptr)

For other common API errors see the API Errors document.

 

Remarks

This function is used to retrieve a parameter from the parameter list handle used in inter-addon communications.
For the utilization details of APIAny_GetMDCLParameterID refer to the Parameter Passing section of the Communication Manager.

 

Example

See the Communication_Client example.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

Communication Manager
API_MDCLParameter
APIAny_AddMDCLParameterID
APIAny_ChangeMDCLParameterID
APIAny_FreeMDCLParameterListID
APIAny_GetMDCLParameterNumID
APIAny_InitMDCLParameterListID
ACAPI_Command_Call
ACAPI_Command_Test
ACAPI_Goodies
API Functions