APIAny_​GetMDCLParameterNumID

Retrieves the number of the parameters on the parameter list.

    GSErrCode ACAPI_Goodies (
        APIAny_GetMDCLParameterNumID,
        GSHandle     params,
        Int32*       nPars
    );

 

Parameters

params
[in] The handle of the parameter list
nPars
[out] Number of the parameters on the list

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
params is nullptr

For other common API errors see the API Errors document.

 

Remarks

This function is used to retrieve the number of the parameters on the parameter list handle used in inter-addon communications.
For the utilization details of APIAny_GetMDCLParameterNumID refer to the Parameter Passing section of the Communication Manager.

 

Example

See the Communication_Client example.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

Communication Manager
APIAny_AddMDCLParameterID
APIAny_ChangeMDCLParameterID
APIAny_FreeMDCLParameterListID
APIAny_GetMDCLParameterID
APIAny_InitMDCLParameterListID
ACAPI_Command_Call
ACAPI_Command_Test
ACAPI_Goodies
API Functions