Returns the position and the normal vector of the given opening.
GSErrCode ACAPI_Goodies ( APIAny_GetOpeningTransformationID, const API_Guid* elemGuid, API_Tranmat* openingTranMat );
Parameters
- elemGuid
- [in] The opening element’s GUID.
- openingTranMat
- [out] The global → local transformation matrix of the opening.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The
openingTranMat
parameter is nullptr. APIERR_DELETED
- The
elemGuid
doesn’t point to a valid element. APIERR_BADID
- The
elemGuid
doesn’t point to a valid opening. APIERR_GENERAL
- The transformation matrix cannot be calculated.
For other common API errors see the API Errors document.
Remarks
The transformation matrix may result in a left-handed coordinate system if the opening is mirrored.
Requirements
- Version: API 20 or later
- Header: APIdefs_Goodies.h