APIAny_​GetParamValuesID

Returns the possible values defined for a Library Part parameter.

    GSErrCode ACAPI_Goodies (
        APIAny_GetParamValuesID,
        API_GetParamValuesType*     getValues
    );

 

Parameters

getValues
[out] the value list for the given parameter

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
theParams is nullptr
APIERR_BADNAME
The parameter specified by its name was not found in the open  library part
APIERR_BADINDEX
The parameter specified by its index was not found in the open  library part
APIERR_NOTINIT
No open parameter list

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the possible values for a given parameter. Refer to the API_GetParamValuesType structure to get further details.

Do not forget to dispose the strValues and the realValues handles when they are not needed any more.

 

Example

See the example given at the APIAny_OpenParametersID function.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_GetParamValuesType
APIAny_OpenParametersID
ACAPI_Goodies
API Functions