APIAny_​GetPropertyExprReferenceStringID

Returns the string that can be used in expressions to refer to a specific property.

    GSErrCode ACAPI_Goodies (
        APIAny_GetPropertyExprReferenceStringID,
        API_PropertyDefinition*    propertyDefinition
        GS::UniString*             propertyReferenceString
    );

 

Parameters

propertyDefinition
[in] The property definition to be refenced by the returned string.
propertyReferenceString
[out] String for storing the returned property reference string.

 

Return Values

NoError
The operation was successful.
APIERR_BADPARS
Some of the parameters are nullptr.

For other common API errors see the API Errors document.

 

Requirements

Version: API 22 or later
Header: APIdefs_Goodies.h

 

See Also

API_LibPart,
ACAPI_Goodies, API Functions