Returns the image of the given room.
GSErrCode ACAPI_Goodies ( APIAny_GetRoomImageID, API_RoomImage* roomImage );
Parameters
- roomImage
- [in/out] The API_RoomImage object containing the parameters for the image and the output generated image.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The
roomImage
parameter or the contained (roomImage->nativeImagePtr
) isnullptr
. APIERR_BADID
- The given GUID (
roomImage->roomGuid
) is invalid.
For other common API errors see the API Errors document.
Remarks
For example code please see the Goodie_Functions example Add-On.
Requirements
- Version: API 23 or later
- Header: APIdefs_Goodies.h