APIAny_​GetSelectedElementID

Converts an API_Neig structure to an API_Guid.

    GSErrCode ACAPI_Goodies (
        APIAny_GetSelectedElementID,
        const API_Neig*          apiNeig,
        API_Guid*                apiGuid
    );

 

Parameters

apiNeig
[in] The Neig describing a point of the Element.
apiGuid
[out] The GUID of the Subelement at that point.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
apiGuid or apiNeig is nullptr.

For other common API errors see the API Errors.

 

Requirements

Version: API 21 or later
Header: APIdefs_Goodies.h

 

See Also

APIAny_SetSelectedElementNeigID,
ACAPI_Goodies, API Functions