APIAny_​GetSplineMaxDistID

Returns the maximal distance of a spline segment and a set of coordinates.

    GSErrCode ACAPI_Goodies (
        APIAny_GetSplineMaxDistID,
        API_TestSplineFit*     splinePars,
        double*                distance
    );

 

Parameters

splinePars
[in] the coordinates and the parameters of the spline to test.
distance
[out] the maximal distance of the coordinates from the requested segment of the spline.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
any of the parameters are nullptr, or the passed handles have wrong sizes.

For other common API errors see the API Errors document.

 

Remarks

This function is used to determine the maximal distance of a segment of a bezier curve and a set of coordinates.

Refer to the API_TestSplineFit structure for the parametrization.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_TestSplineFit,
ACAPI_Goodies, API Functions