Returns the length of a line of text in mms.
GSErrCode ACAPI_Goodies ( APIAny_GetTextLineLengthID, API_TextLinePars* textLinePars, double* length );
Parameters
- textLinePars
- [in] parameters of the text to be measured
- length
- [out] the length of the text
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- one or both of the parameters are
nullptr
For other common API errors see the API Errors document.
Remarks
The index
field of textLinePars
determines the behavior of the function.
index
Behavior
-1
No line terminator; this is the last line of the text.
0
Line terminators are in the text; measure the whole string in
textLinePars->lineStr
.
> 0
Length of the line with the specified index.
The textLinePars->drvScaleCorr
field determines whether any drawing scale correction is applied.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Goodies.h