APIAny_​GetTextSizeFactorID

Returns the ratio of the font capital size and typography size.

    GSErrCode ACAPI_Goodies (
        APIAny_GetTextSizeFactorID,
        short*      api_fontID,
        double*     textSizeFactor
    );

 

Parameters

api_fontID
[in] Font attribute index.
textSizeFactor
[out] The ratio of the font capital size and typography size.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Any of the parameters are nullptr.

For other common API errors see the API Errors document.

 

Remarks

Archicad uses the capital font size. This function is used to determine the ratio of the font capital size and typographical size.

 

Requirements

Version: API 5.1 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies,
API Functions