APIAny_​GetTextureCoordID

Returns the texture coordinates of the given surface point.

    GSErrCode ACAPI_Goodies (
        APIAny_GetTextureCoordID,
        API_TexCoordPars*     texCoordPars,
        API_UVCoord*          uvCoord
    );

 

Parameters

texCoordPars
[in] identifies the surface point
uvCoord
[out] the local (u, v) coordinate system of the texture

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
one or both of the parameters are nullptr
APIERR_GENERAL
Couldn’t get the texture coordinates

For other common API errors see the API Errors document.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_TexCoordPars, API_UVCoord, ACAPI_Goodies,
API Functions