Retrieves the name of a Libpart, even if the library is unloaded.
GSErrCode ACAPI_Goodies ( APIAny_GetUnloadedLibpartNameID, const API_Guid* guid, GS::UniString* name );
Parameters
- guid
- [in] the guid of the Object, Lamp, Window or Door element.
- name
- [out] the name of the Libpart
Return Values
NoError
- The function has completed with success.
APIERR_BADID
guid
isnullptr
For other common API errors see the API Errors document.
Remarks
This function is used to get the name of a library part even if the library is unloaded
For more information about library parts see API_LibPart.
Requirements
- Version: API 13.0 or later
- Header: APIdefs_Goodies.h