It converts an IfcGloballyUniqueId string to an API_Guid.
GSErrCode ACAPI_Goodies ( APIAny_IFCGuidToAPIGuidID, const GS::UniString* ifcGuid, API_Guid* apiGuid );
Parameters
- ifcGuid
- [in] IfcGloballyUniqueId string that has to be converted.
- apiGuid
- [out] The resulting API_Guid.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- If any error occured during the conversion.
For other common API errors see the API Errors document.
Remarks
It converts an IfcGloballyUniqueId string to an API_Guid.
For example “32vZ_y6Kf8bQUeOicmrSnx” is converted to “C2E63FBC-194A-4895-A7A8-62C9B0D5CC7B”
Requirements
- Version: API 18 or later
- Header: APIdefs_Goodies.h