APIAny_​InterpretGDLScript3DID

Interprets a 3D GDL script with the same settings as GDL Editor.

    GSErrCode ACAPI_Goodies (
        APIAny_InterpretGDLScript3DID,
        const GS::UniString*            script,
        API_AddParType**                addPars,
        ModelerAPI::Model*              modelerAPIModel,
        Modeler::ConstModel3DPtr*       modelerModel
    );

 

Parameters

script
[in] The 3D GDL Script.
addPars
[in] Parameters for script running. Can be NULL, in this case the script will run with empty parameter list.
modelerAPIModel
[out] The generated 3D model as ModelerAPI::Model. Use either this or the modelerModel, but only one at the same time.
modelerModel
[out] The generated 3D model as Modeler::ConstModel3DPtr. Use either this or the modelerAPIModel, but only one at the same time.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Incorrect parameters were specified.
APIERR_GENERAL
Failed to interpret the script.

For other common API errors see the API Errors document.

 

Requirements

Version: API 24 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies,
API Functions