Returns the element type assigned to a neig.
GSErrCode ACAPI_Goodies ( APIAny_NeigIDToElemTypeID, const API_NeigID* neigID, API_ElemTypeID* elemTypeID );
Parameters
- neigID
- [in] neig identifier
- elemTypeID
- [out] element type identifier
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- any of the parameters are
nullptr
APIERR_BADID
- Invalid
neigID
has been passed
For other common API errors see the API Errors document.
Remarks
This function is used to convert a neig identifier to element type.
Refer to the API_NeigID structure to get information how neigs are assigned to elements.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Goodies.h