Converts a picture into another image format.
GSErrCode ACAPI_Goodies ( APIAny_PolygonId2SurfaceTypeID, const API_Element* elem, const Int32* polygonId, API_SurfaceTypeID* surfaceType );
Parameters
- elem
- [in] Parameter
elem
for element type identification. Give elem.header.guid or elem.header.typeId. For roofs specifyelem.roof.roofClass
also. - polygonId
- [in] Parameter
polygonId
. - surfaceType
- [out] Parameter
surfaceType
.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- parameters are nullptr or invalid
APIERR_BADID
- elemGuid does not refer to a valid element in the database.
Remarks
This function is used to convert a polygonId returned by ModelerAPI::Polygon::GetPolygonId to a API_SurfaceTypeID.
Requirements
- Version: API 20 or later
- Header: ACAPI_Goodies.h, APIdefs_SurfaceType.h