APIAny_​RegularizePolygonID

Regularizes a polygon and returns the regularized polygons.

    GSErrCode ACAPI_Goodies (
        APIAny_RegularizePolygonID,
        API_RegularizedPoly*       polygon,
        Int32*                     nResult,
        API_RegularizedPoly***     regularizedPolygons
    );

 

Parameters

polygon
[in] The polygon to regularize.
nResult
[out] The number of resulting regularized polygons.
regularizedPolygons
[out] The result of regularization.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
any of the parameters are nullptr or polygon or regularizedPolygons is not initialized
APIERR_MEMFULL
low memory condition

For other common API errors see the API Errors document.

 

Remarks

This function is used to regularize a polygon. The result may be 0, 1 or more regularized polygons.

Refer to the API_RegularizedPoly structure to have more details on the polygon data structure.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_RegularizedPoly,
APIAny_RegularizePolylineID, APIAny_DisposeRegularizedPolyID,
ACAPI_Goodies, API Functions