Regularizes a polyline and returns the regularized polyline.
GSErrCode ACAPI_Goodies ( APIAny_RegularizePolylineID, API_RegularizedPoly* polyline, API_RegularizedPoly* regularizedPolyline );
Parameters
- polyline
- [in] The polyline to regularize.
- regularizedPolyline
- [out] The result of regularization.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- any of the parameters are
nullptr
orpolyline
orregularizedPolyline
is not initialized APIERR_MEMFULL
- low memory condition
For other common API errors see the API Errors document.
Remarks
This function is used to regularize a polyline. A polyline is considered irregular when two or more consecutive vertices in the coord array are the same.
The result may be an empty polyline.
Refer to the API_RegularizedPoly structure to have more details on the polyline data structure.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Goodies.h
See Also
API_RegularizedPoly,
APIAny_RegularizePolygonID, APIAny_DisposeRegularizedPolyID,
ACAPI_Goodies, API Functions