APIAny_​RunGDLParScriptID

Run GDL parameter script.

    GSErrCode ACAPI_Goodies (
        APIAny_RunGDLParScriptID,
        const API_Elem_Head*  elemHead,
        UInt32                mask
    );

 

Parameters

elemHead
[in] Head of the element. It is identified by the guid field.
mask as value
Element mask; can be APIElemMask_FromFloorplan (= use the element from the floor plan).

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The element doesn’t exist.

For other common API errors see the API Errors document.

 

Remarks

You are eble to run the GDL parameter script of an object, lamp, window or door element via this function.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 12 or later
Header: APIdefs_Automate.h

 

See Also

ACAPI_Goodies, API Functions