APIAny_​SetEmptyHoleUnIdID

Sets the unique ID of the empty hole.

    GSErrCode ACAPI_Goodies (
        APIAny_SetEmptyHoleUnIdID,
        GSType*         signature,
        const char*     emptyHoleUnIdStr,
        const char*     emptyOpeningSubtypeUnIDStr
    );

 

Parameters

signature
[in] A four-character identifier of this library part subtype.
emptyHoleUnIdStr
[in] The unique ID string of this library part subtype.
emptyOpeningSubtypeUnID

 

Return Values

NoError
The function has completed with success.
APIERR_NOTSUPPORTED
The root type is not window or door.

For other common API errors see the API Errors document.

 

Remarks

This function is used to set the unique ID of the empty hole. It works only on window or door subtype.

 

Example


//------------------------------------------------------
// Called after the Add-On has been loaded into memory
//------------------------------------------------------
GSErrCode __ACENV_CALL    Initialize (void)
{
    GSErrCode    err;

    const char* emptyHoleUnIdStr = "{423059FF-C9C6-4368-9448-F82F47AAFC65}-{3E919DA8-41A0-4968-A2AE-875F1B56D2A2}";
    err = ACAPI_Goodies (APIAny_SetEmptyHoleUnIdID, (void*) (Int32) 'CRWD', (void*) emptyHoleUnIdStr);

    return err;
} //Initialize

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies, API Functions, ACAPI_Register_Subtype