APIAny_​SetMasterLayoutOnLayoutID

Sets the layout context of current database for drawing.

    GSErrCode ACAPI_Goodies (
        APIAny_SetMasterLayoutOnLayoutID,
        API_DatabaseUnId*                  databaseUnId
    );

 

Parameters

databaseUnId
[in] The database identifier of the layout context.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
databaseUnId is nullptr or a non existing database identifier.

For other common API errors see the API Errors document.

 

Remarks

This function is used to set the layout context of the current database, when current database is a master layout.

Use this function after changed to a master layout of the given layout with APIDb_ChangeCurrentDatabaseID. When this function successfully completed, the datas (autotexts, etc.) on master layout will be shown in the context of the given layout.

 

Requirements

Version: API 18 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies, API Functions