APIAny_​SolveStairID

Creates a valid stair baseline from invalid data.

    GSErrCode ACAPI_Goodies (
        APIAny_SolveStairID,
        API_StairType*            apiStair,
        API_ElementMemo*          apiMemo,
        API_StairSolutionID*      solution
    );

 

Parameters

apiStair Changed in API 22
[in/out] The stair element to be checked.
apiMemo
[in/out] The memo of the stair element to be checked.
solution
[out] The result of the operation:

APISS_Correct

The baseline was already correct, no operation was needed.

APISS_Solved

The baseline was successfully solved.

APISS_NotSolved

The baseline could not be solved.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
baseline or solution is nullptr.

For other common API errors see the API Errors.

 

Requirements

Version: API 21 or later
Header: APIdefs_Goodies.h

 

See Also

APIAny_GetSelectedElementID,
ACAPI_Goodies, API Functions