APIAttributeReplacementHandlerProc

User supplied callback procedure for handling attribute replacements.

    typedef GSErrCode  APIAttributeReplacementHandlerProc (
        const API_AttributeReplaceIndexTable&   table
    );

 

Parameters

table
[in] List of attributes replaced. The hash key in the hash table is the type of attribute (material, profile etc.), the paired value is another hash table, which holds the old (deleted) attribute indices as keys, and the replacement attribute indices as values.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This callback function should be implemented and set with ACAPI_Notify_CatchAttributeReplacement in order to receive notifications of attribute replacements.

 

Example

See the Examples section of ACAPI_Notify_CatchAttributeReplacement.

 

Requirements

Version: API 25 or later
Header: ACAPinc.h

 

See Also

ACAPI_Notify_CatchAttributeReplacement
API Functions