Callback function to handle the visibility of a classification.
typedef bool APIClassificationVisibilityHandlerProc ( API_ClassificationVisibilityMode visibilityMode const GS::Array<API_Guid>& classificationGuids const API_Guid& classificationItemGuid );
Parameters
- visibilityMode
- [in] specifies what should the callback function return. Has one of the following values:
Meaning
APIClassVis_IsEnabled
The callback function should return true if the visibility handling is enabled.
APIClassVis_IsClassificationVisible
The callback function should return true if the given classification is visible.
- classificationGuids
- [in] the classification guids of the current element.
- classificationItemGuid
- [in] the guid of the current classification.
Return Values
- The result.
For other common API errors see the API Errors document.
Example
static bool __ACENV_CALL ClassificationVisibilityHandler (API_ClassificationVisibilityMode visibilityMode, const GS::Array<API_Guid>& classificationGuids, const API_Guid& classificationItemGuid) { if (visibilityMode == APIClassVis_IsEnabled) { // returns true if the classification visibility handling enabled, false otherwise // ... } else if (visibilityMode == APIClassVis_IsClassificationVisible) { // returns true if the classification should be shown, false otherwise // ... } return true; }
Requirements
- Version: API 21 or later
- Header: APIdefs_Callback.h