APICommandCallBackProc

Callback function for handling the responses of asynchronous module command calls from main event loop.

    typedef void  APICommandCallBackProc (
        GSHandle*      paramsHandle,
        GSPtr      resultData,
        GSErrCode     returnCode
    );

 

Parameters

paramsHandle
[in/out] pointer to the passed parameters for the module command
resultData
[in] optional result data from the APIModulCommandProc function of the server side add-on
returnCode
[in] the return value of the APIModulCommandProc function of the server side add-on

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This is the handler function to be used for collecting the results of module command calls in asynchronous case.

For more details refer to the description of the ACAPI_Command_CallFromEventLoop function.

 

Requirements

Version: API 19 or later
Header: APIdefs_Callback.h

 

See Also

ACAPI_Command_CallFromEventLoop
Communication Manager
API Functions