APIDb_​BreakHotlinkNodeID

Breaks the link of the given hotlink node.

    GSErrCode ACAPI_Database (
        APIDb_BreakHotlinkNodeID,
        const API_Guid*     hotlinkNodeGuid
    );

 

Parameters

hotlinkNodeGuid
[in] guid of the hotlink node to be broken

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
hotlinkNodeGuid parameter is nullptr.
APIERR_BADID
hotlinkNodeGuid is invalid.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.

For other common API errors see the API Errors document.

 

Remarks

This function deletes the hotlink node identified by the hotlinkNodeGuid parameter. Unlike APIDb_DeleteHotlinkNodeID the instance elements are not deleted from the project, but converted into normal elements grouped together.

 

Requirements

Version: API 12 or later
Header: APIdefs_Database.h

 

See Also

API_HotlinkNode
APIDb_GetHotlinkNodeID
APIDb_CreateHotlinkNodeID
APIDb_ModifyHotlinkNodeID
APIDb_DeleteHotlinkNodeID
ACAPI_Database
API Functions