APIDb_​CalcBoundsID

Returns the model extent of an element of the current database.

    GSErrCode ACAPI_Database (
        APIDb_CalcBoundsID,
        const API_Elem_Head*     elemHead,
        API_Box3D*               extent3D
    );

 

Parameters

elemHead
[in] the element reference
extent3D
[out] the 3D enclose box of the element

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Any of the parameters are nullptr.
APIERR_BADID
elemHead->guid is invalid.
APIERR_DELETED
The element is deleted.

For other common API errors see the API Errors document.

 

Remarks

This function is used to determine the model extent of an element. It can be used either to construction or 2D element. In the second case the vertical information will be not filled.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

API_Elem_Head, API_Box3D,
ACAPI_Database, API Functions