APIDb_​ChangeDrawingScaleID

Changes the drawing scale.

    GSErrCode ACAPI_Database (
        APIDb_ChangeDrawingScaleID,
        double*     scale,
        bool*       zoom
    );

 

Parameters

scale
[in] The new scale for the drawing.
zoom
[in] Perform a rebuild command after changing the scale.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
dScale is nullptr or contains wrong value.

For other common API errors see the API Errors document.

 

Remarks

This function is used to change the drawing scale of the plan. The scale has to be greater than 1 and smaller than 30000.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

APIDb_GetDrawingScaleID
ACAPI_Database
API Functions