APIDb_​ChangeElementInfoStringID

Changes the compound info string of the given element.

    GSErrCode ACAPI_Database (
        APIDb_ChangeElementInfoStringID,
        const API_Guid*         elementGuid,
        const GS::UniString*    infoString
    );

 

Parameters

elementGuid
[in] the Guid of the element
infoString
[in] the info string of the element

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
any of the parameters is nullptr
APIERR_BADID
no element found by the specified Guid
APIERR_BADELEMENTTYPE
element has no info string

For other common API errors see the API Errors document.

 

 

Requirements

Version: API 22 or later
Header: APIdefs_Database.h

 

See Also

API_Elem_Head
APIDb_GetCompoundInfoStringID
ACAPI_Database
API Functions