APIDb_​ChangeGridSettingsID

Changes the grid setting parameters of the current database.

    GSErrCode ACAPI_Database (
        APIDb_ChangeGridSettingsID,
        API_GridType*     gridPars
    );

 

Parameters

gridPars
[out] the grid parameters

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
gridPars is nullptr

For other common API errors see the API Errors document.

 

Remarks

This function is used to change the parameters of the actual grid setting. It is database dependent, each database may have different grid parameters set. The actual setting parameters can be got with the APIDb_GetGridSettingsID function.  

Example


API_GridType        gridPars;
GSErrCode           err;

BNZeroMemory (&gridPars, sizeof (API_GridType));
err = ACAPI_Database (APIDb_GetGridSettingsID, &gridPars, nullptr);
if (err == NoError) {
    gridPars.gridSwitch = !gridPars.gridSwitch;
    err = ACAPI_Database (APIDb_ChangeGridSettingsID, &gridPars, nullptr);
}

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

API_GridType,
APIDb_GetGridSettingsID,
ACAPI_Database, API Functions